Im WP Repository: 

Screenshot P.S.I.

This wordpress plugin shows some security and age information about the currently installed plugins. it shows the age in colors from green to orange to red, and displays the age as a bar, so you can easily find the problematic plugins. also a warning is displayed if the plugin is not in wordpress.org and must be updates manually which is a sign of a problematic plugin.

You can see the additional information in the 3rd column in the screenshot. Also it works nicely together with „better plugin compatibilty control“ which you can see in the 1st column, which also gives nice information about age and compatibility.

Contact

You can reach me via the contact form.